JTL-Wawi Connector für Virtuemart by web-signs :: Installation
JTL-Wawi Connector für Virtuemart by web-signs :: Installation
Version: 1.5.4-5
Demoversion    aktuell ist v.1.5.4-5 (2011-10-20)
Prüfung
Einstellungen
Installation


Prüfung
Prüfung

Hinweise zu dieser Demoversion

Für diese Demoversion gelten folgende Prämissen:
  • Benutzername und Passwort für den Synchronisations-Benutzer können nicht geändert werden.
  • Die Installation kann uneingeschränkt - wie in der Dokumentation beschrieben - durchgeführt werden.
  • Nach Abschluß der Installation ist der Administrationsbereich über die angegebene URL erreichbar.
  • Im Administrationsbereich kann die Konfiguration jederzeit geändert werden.
  • Eine Verbindung mit JTL-Wawi ist möglich und kann getestet werden.
    Wichtiger Hinweis: Eine Synchronisation zwischen der verbundenen JTL-Wawi und diesem Shop erfolgt nicht! - Diese Funktionalität ist im Demo-Modus inaktiv.
  • Die Installationsschritte können beliebig oft wiederholt werden, da im Demomodus vor jeder Installation ein Reset durchgeführt wird.
 
Bei Interesse an diesem Connector wenden Sie sich bitte an rbaier@web-signs.de.
Weitergehende Informationen finden sich hier.


Vorbemerkung

Bei dieser Version des "JTL-Wawi Connector für VirtueMart" handelt es sich um eine von der Internetagentur web-signs entwickelte Lösung.
Die Programmierung erfolgte auf Basis des von JTL-Software angebotenen Connectors. Ein anderer Ansatz konnte derzeit auch gar nicht gewählt werden, da nur die Kenntnis der JTL-Wawi-API (die aus dem vorhandenen Code tlw. erkennbar wird) die Programmierung eines solchen Connectors ermöglicht. Der Programmcode wurde komplett umgeschrieben, um auf die Möglichkeiten, die das Joomla!-Framework bietet, voll zugreifen zu können.

Informationen zum Synchronisationsumfang finden sich HIER.

Diese Version des Connectors ist getestet und lauffähig mit Joomla! bis v.1.5.25, Virtuemart bis v.1.1.9 sowie JTL-Wawi v.0.9.9.780.


Bei Fragen oder Problemen wenden Sie sich bitte an rbaier@web-signs.de.

Mein besonderer Dank gilt Christoph Käufer, der die Headergrafik gestaltet hat.

Prüfung

Der "JTL-Wawi Connector für VirtueMart by web-signs" funktioniert mit allen Joomla!-Versionen (1.0.x ... 1.5.x) sowie allen Virtuemart-Versionen (1.0.x ... 1.1.x).

Ihre Joomla!-Version: Joomla! 1.0.15 Stable  OK!
Ihre Virtuemart-Version: VirtueMart 1.0.15 stable   OK!

Kleine Anmerkung: Bitte nicht von der URL irritieren lassen - da Google diese Testinstallation sehr gut listet, möchte ich das Unterverzeichnis nicht mehr umbenennen ;-)

Installation oder Upgrade bzw. Update

Im Normalfall muß der Connector installiert werden. Dabei wird eine vorhandene Joomla!-/Virtuemart-Installation vorausgesetzt.
Falls bereits ein anderer Connector verwendet wurde - die ursprünglichen Joomla!-/Virtuemart-Versionen jedoch zwischenzeitlich auf die aktuellsten Versionen migriert wurden, ist ein "Upgrade" unbedingt zu empfehlen, da andernfalls alle Mapping-Informationen verloren gehen würden (bei einem "Upgrade" bleiben alle Mapping-Tabellen erhalten - lediglich die Tabelle, die Ihre Einstellungen speichert und die Tabelle, die die Informationen zum Synchronisationsbenutzer enthält, wird modifiziert). Ein "Upgrade" ist auch dann anzuwenden, wenn lediglich ein anderer Connector durch diesen ersetzt werden soll oder eine ätere Version dieses Connectors durch eine aktuelle ersetzt werden soll (Update).

Bitte legen Sie hier fest, ob eine Installation oder ein Upgrade des Connectors durchgeführt weden soll.
Installation oder Upgrade bzw. Update: Installation
Upgrade / Update